Results 1 to 5 of 5

Thread: 32e problem

  1. #1

    32e problem

    51fl all stock electrical system. I just rode from ND to Minden, NV . Great trip. About 100 miles out my generator light came on and wont go out unless I turn the headlight on and leave it on. This happened right after a battery hold down nut came off and shorted out the positive post to the frame. Fuse blew. I put the nut back where it belonged and put in a new fuse and away I went. About a mile later the gen light came on and stays on unless I use the headlight. I plan to file the contacts in the cutout but other than that I don't know what to do.

  2. #2

    Re: 32e problem

    My thinking is you burned another wire somewhere when it blew the positive. I was on a ride when the positive shorted out and fried everything even on the dash. Had to wait for a friend to show up with a full roll of electrical tape and padded everything with it. Made it home to find my complete wire harness was fried.

  3. #3

    Re: 32e problem

    Boy, idk. I noticed now that with the engine running and the headlines on then turn lites off with engine running, lite stays on with switch in ignition position .

  4. #4

    Re: 32e problem

    May be you are running on the third brush only now ?

  5. #5

    Re: 32e problem

    Update. Messed with it most of the day. Finally disconnected the headlight wires from the terminal board. All is well now except no headlight. I can use the spots if I need to I guess. The 68 year old wiring or the switch must have a bad spot someplace. Not equipped to remove tanks, dash, and handlebars to rewire here. Gonna go without headlight and hope for the best. Too far from home to push.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Does this look like a problem ?
    By grantracy in forum General Motorcycle Discussion
    Replies: 5
    Last Post: 03-02-2014, 07:37 PM
  2. problem with my M5
    By 38knuckle in forum Carburetor, Air Cleaner & Exhaust
    Replies: 6
    Last Post: 08-01-2011, 01:21 PM
  3. 800 Lb Bike.....No problem.
    By Mr. Big in forum Riding Skills & Motorcycle Laws
    Replies: 3
    Last Post: 07-23-2011, 07:59 PM
  4. Electrical problem
    By 64Panhead in forum Electrics & Ignition
    Replies: 12
    Last Post: 02-22-2011, 03:54 PM
  5. Oil problem
    By 48panshovel in forum Harley 1936-1964
    Replies: 3
    Last Post: 07-27-2009, 05:02 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •